Audio source stop if I Remote Desktop the computer

4 weeks 2 days ago 4 weeks 2 days ago by bootika. Reason: correction
bootika
Nuovo Utente
Nuovo Utente
Posts: 4
More
Topic Author
Audio source stop if I Remote Desktop the computer #84537
Hello

I installed yesterday MB Recaster and all is great except one annoying thing:
If I connect to the computer running MB Recaster using Remote Desktop (RDP protocol from Microsoft) the audio source stops inside MB Recaster. The audio source continues to play (I see the VU-meter inside Playback Devices system window). MB Recaster looses the signal somehow.. I have to reselect the audio card in MB Recaster in order to restart playing (or interact with the the "Exclusive" checkbox). Then all is good again
The problem is that when I exit the RDP session, it stops again :) And I cannot start it (and stay that way), unless I go in front of the computer. :)) Does anybody have the same issue? Any ideas?
I disabled the audio redirection (playback and record) inside from Local Group Policy\Administrative Templates\Windows Components\Remote Desktop Services\
Allow audio and video playback redirection - Disabled
Allow audio recording redirection - Disabled
Still no good

See attached images please
Attachments:

Please Log in or Create an account to join the conversation.

4 weeks 2 days ago 4 weeks 2 days ago by MB SOFT.
MB SOFT
Amministratore
Amministratore
Posts: 8969
More
Audio source stop if I Remote Desktop the computer #84550
I just checked and i can confirm the problem. When an RDP session start or finish Windows disconnect/reconnect the audio lines and leave MB RECASTER with no data input until you manually restart the capture session (changing audio card selector, changing exclusive flag or restarting the application). This is a general issue affecting any audio application capturing sound from WASAPI. Unfortunately i don't have a workaround for this. You'll probably get the same using any other encoder around. Maybe i can make MB RECASTER to check for the audio line status and auto reset itself when necessary but this would cause an audio skip for the listeners. I suppose the best solution would be to avoid RDP session and use other remote desktop viewers like ex Supremo www.supremocontrol.com/

Per inviare un debug seguire queste istruzioni: www.mbradio.it/it/guida/333-supporto-come-segnalare-un-problema
Il 99% dei problemi di un computer sta tra la sedia e la tastiera :)

Please Log in or Create an account to join the conversation.

4 weeks 1 day ago
bootika
Nuovo Utente
Nuovo Utente
Posts: 4
More
Topic Author
Audio source stop if I Remote Desktop the computer #84556
Thank you. Better a short audio skip than nothing :) I will also try to replace RDP with something else, but I am an Sysadmin and RDP has some advantages for me, especially when connecting in cascade, using my computer as jump guest. Anyway, thank you for your quick reply

Please Log in or Create an account to join the conversation.

4 weeks 1 day ago
paul03034
Utente Esperto
Utente Esperto
Posts: 83
More
Audio source stop if I Remote Desktop the computer #84561
I would not use remote desktop at all as I have had too many issues with it.

Try AnyDesk or Remote Utilities programs just Google them. Set them up for unattended access and you will be good to go.

I recommend AnyDesk is the best free version which is just about as fast as TeamViewer, but is free for personnel use and not expensive if you pay. I don't use TeamViewer due to cost.
I'll pay for AnyDesk usage, but not TeamViewer as you can pay $79 a year or buyout at $349 for lite version. I am using free right now, but they deserve something if you really use it all the time.

Also no VPN needed or router configuration using AnyDesk. I used VNC before and did VPN, but too slow and no audio at least how I had it set.
I have multiple network connections so no complicated setting.
My servers are on a mountaintop, so this works great for me!

Hope this helps!

Please Log in or Create an account to join the conversation.

2 weeks 5 days ago
bootika
Nuovo Utente
Nuovo Utente
Posts: 4
More
Topic Author
Audio source stop if I Remote Desktop the computer #84611
Do you have an approximate ETA for making MB RECASTER to check for the audio line status and auto reset itself when necessary?
Thank you,

Please Log in or Create an account to join the conversation.

1 week 3 days ago
MB SOFT
Amministratore
Amministratore
Posts: 8969
More
Audio source stop if I Remote Desktop the computer #84644
It will be out next week.

Per inviare un debug seguire queste istruzioni: www.mbradio.it/it/guida/333-supporto-come-segnalare-un-problema
Il 99% dei problemi di un computer sta tra la sedia e la tastiera :)

Please Log in or Create an account to join the conversation.

5 days 10 hours ago
bootika
Nuovo Utente
Nuovo Utente
Posts: 4
More
Topic Author
Audio source stop if I Remote Desktop the computer #84660
Thanks a lot, works great now when entering Remote Desktop! A small skip, but anyway acceptable.. And no skip on RDP exit! :)
The following user(s) said Thank You MB SOFT

Please Log in or Create an account to join the conversation.

Time to create page: 0.271 seconds