Audio rallentato con scheda M-AUDIO MobilePre USB

  • Topic Author
10 Jun 2011 18:43 - 15 Jun 2011 22:35 #57407 by
Salve Maurizio,
oggi ho riscontrato un problema: l'audio che veniva ricevuto dalla postazione di MB Studio 8.46 (inviato da MB Live 1.46) era leggermente rallentato, dando un effetto di "tono basso" alle voci.

Hai qualche idea su come risolvere questo problema? Con la versione precedente funzionava tutto perfettamente, l'unica modifica che ho effettuato è stata quella di cambiare il profilo: prima facevo lo stream da MB Live con MP3 128 Kbits Stereo mentre oggi ho scelto AAC+ 64 Kbits Stereo ma non penso che sia dovuto a questo o forse mi sbaglio?

Un'altra cosa: MB Studio si collega ad Icecast con uno stream MP3 192 Kbits Stereo, come mai da MB Live il massimo profilo disponibile con il codec MP3 è 192 Kbits ma in Mono?

Grazie per la tua disponibilità, se hai bisogno di dettagli aggiuntivi posso fornirti le varie configurazioni e anche un pezzo di audio che ho registrato in cui si sente questo difetto.
Last edit: 15 Jun 2011 22:35 by .

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 19:02 - 15 Jun 2011 22:35 #57410 by MB SOFT

oggi ho riscontrato un problema: l'audio che veniva ricevuto dalla postazione di MB Studio 8.46 (inviato da MB Live 1.46) era leggermente rallentato, dando un effetto di "tono basso" alle voci.
Hai qualche idea su come risolvere questo problema?

Probabilmente la scheda audio del computer ove hai installato MB LIVE ha dei problemi. Puoi provare ad aggiornarne i drivers.

Con la versione precedente funzionava tutto perfettamente, l'unica modifica che ho effettuato è stata quella di cambiare il profilo: prima facevo lo stream da MB Live con MP3 128 Kbits Stereo mentre oggi ho scelto AAC+ 64 Kbits Stereo ma non penso che sia dovuto a questo o forse mi sbaglio?

Non fa differenza in quanto in entrambi i casi il campionamento avviene a 44100 hz 16 bits stereo. In ogni caso non c'è alcuna differenza di funzionamento tra questo MB LIVe e i precedenti nella modalita' di cattura audio dalla scheda audio.

Un'altra cosa: MB Studio si collega ad Icecast con uno stream MP3 192 Kbits Stereo, come mai da MB Live il massimo profilo disponibile con il codec MP3 è 192 Kbits ma in Mono?

Hai ragione, è un bug grafico...è scritto Mono ma in realta' è stereo

Il forum non sostituisce il servizio di assistenza tecnica. Per ricevere assistenza tecnica andare a questa pagina: www.newradio.it/client/submitticket.php?step=2&deptid=4
Pour signaler un problème, lisez ici: www.mbradio.it/fr/soutien/guide/713-sout...signaler-un-probleme
Last edit: 15 Jun 2011 22:35 by .

Please Log in or Create an account to join the conversation.

  • barty
10 Jun 2011 20:06 - 15 Jun 2011 22:35 #57413 by barty
credo sia un problema di AAC+  a mè lo fa a volte anche il winamp quando passo da una radio in mp3 ad un'altra in AAC+.. riavvio winamp e tutto si sistema..
Last edit: 15 Jun 2011 22:35 by .

Please Log in or Create an account to join the conversation.

  • Topic Author
10 Jun 2011 20:10 - 15 Jun 2011 22:35 #57414 by

Probabilmente la scheda audio del computer ove hai installato MB LIVE ha dei problemi. Puoi provare ad aggiornarne i drivers

La scheda audio utilizzata è una M-AUDIO MobilePre USB e questi sono i driver che ho installato: www.m-audio.com/index.php?do=support&tab...ff458be3&OS=x72#tabs

Il driver lavora con latency a 128 (che ho diminuito rispetto al default che era, se non erro, 256).

La scheda viene collegata ad un MacBook 5,1 (P8600, 2,72Gb (di cui 4 installati)), nella 2° USB (quella lontana dal monitor - avevo letto che se collegata nell'altra poteva dare problemi di click) su Windows XP PRO ENG SP3 32bit. Il sistema lo tengo sempre efficiente, senza orpelli grafici e abbastanza aggiornato. In questo caso effettuerò comunque un giro su Windows Update.

Non fa differenza in quanto in entrambi i casi il campionamento avviene a 44100 hz 16 bits stereo. In ogni caso non c'è alcuna differenza di funzionamento tra questo MB LIVe e i precedenti nella modalita' di cattura audio dalla scheda audio.

Perfetto: un dubbio in meno!

Hai ragione, è un bug grafico...è scritto Mono ma in realta' è stereo

Ottimo a sapersi.

credo sia un problema di AAC+  a mè lo fa a volte anche il winamp quando passo da una radio in mp3 ad un'altra in AAC+.. riavvio winamp e tutto si sistema..

Però questo è molto interessante... La prossima volta farò lo stream direttamente in OOG 128 Kbits Stereo oppure l'MP3 192 Kbits Stereo. Se Maurizio conferma il problema di AAC+ abbiamo trovato un fatto davvero interessante di cui tener conto.
Last edit: 15 Jun 2011 22:35 by .

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 21:34 - 15 Jun 2011 22:35 #57417 by MB SOFT

Se Maurizio conferma il problema di AAC+ abbiamo trovato un fatto davvero interessante di cui tener conto.

Io non ho mai "sentito" questo problema, comunque se vuoi allegare uan registrazione audio del problema, sara' piu' chiaro capire di cosa stiamo parlando.
forse non è un cambiamento del pitch ma un problema di buffer che va underrun a causa di un rallentamento dei dati in arrivo. Il buffer di MB STUDIO è a 500 ms?

Il forum non sostituisce il servizio di assistenza tecnica. Per ricevere assistenza tecnica andare a questa pagina: www.newradio.it/client/submitticket.php?step=2&deptid=4
Pour signaler un problème, lisez ici: www.mbradio.it/fr/soutien/guide/713-sout...signaler-un-probleme
Last edit: 15 Jun 2011 22:35 by .

Please Log in or Create an account to join the conversation.

  • Topic Author
13 Jun 2011 13:27 - 15 Jun 2011 22:35 #57451 by

Io non ho mai "sentito" questo problema, comunque se vuoi allegare uan registrazione audio del problema, sara' piu' chiaro capire di cosa stiamo parlando.

Fatto: nella parte iniziale c'è l'audio originale, nella seconda parte l'audio registrato.

forse non è un cambiamento del pitch ma un problema di buffer che va underrun a causa di un rallentamento dei dati in arrivo. Il buffer di MB STUDIO è a 500 ms?

Lavorando sull'audio registrato mi è sembrato proprio un problema di pitch, circa il 15/20% più basso rispetto all'originale. In MB Studio ti confermo che è impostato come buffer 500ms.
Last edit: 15 Jun 2011 22:35 by .

Please Log in or Create an account to join the conversation.

More
13 Jun 2011 13:36 - 15 Jun 2011 22:36 #57452 by MB SOFT
Se non erro sembra la differenza tra 48000 hz e 44100 hz .... in tal caso significa che nel pc dove gira MB LIVE, sebbene MB LIVe chieda audio campionato a 44100, la scheda lo fornisce a 48000 hz  ... è soltanto un'ipotesi ma è l'unica spiegazione logica. Se ho capito bene utilizzi un MAc con emulazione Windows, per cui la faccenda si fa' davvero difficile da risolvere. Dovresti provare con un notebook o netbook con Windows nativamente installato.

Il forum non sostituisce il servizio di assistenza tecnica. Per ricevere assistenza tecnica andare a questa pagina: www.newradio.it/client/submitticket.php?step=2&deptid=4
Pour signaler un problème, lisez ici: www.mbradio.it/fr/soutien/guide/713-sout...signaler-un-probleme
Last edit: 15 Jun 2011 22:36 by .

Please Log in or Create an account to join the conversation.

  • Topic Author
14 Jun 2011 12:38 - 15 Jun 2011 22:36 #57469 by
Ho un MacBook, ma dato che ha un processore Intel, ho Windows XP installato in una partizione a parte dedicata solamente alla regia mobile, quindi non c'è alcun genere di emulazione.

Per quanto riguarda la scheda verifico la frequenza dal driver M-Audio, ma sono abbastanza sicuro che abbia lavorato a 44.100Hz.
Last edit: 15 Jun 2011 22:36 by .

Please Log in or Create an account to join the conversation.

More
14 Jun 2011 13:18 #57472 by MB SOFT
Replied by MB SOFT on topic Re: Audio rallentato

Per quanto riguarda la scheda verifico la frequenza dal driver M-Audio, ma sono abbastanza sicuro che abbia lavorato a 44.100Hz.


Ok allora prova a fare qualche diretta usando la scheda audio integrata del notebook, se da li' il problema non si verifica, allora l'indagine deve proseguire esclusivamente sulla scheda audio M-Audio

Il forum non sostituisce il servizio di assistenza tecnica. Per ricevere assistenza tecnica andare a questa pagina: www.newradio.it/client/submitticket.php?step=2&deptid=4
Pour signaler un problème, lisez ici: www.mbradio.it/fr/soutien/guide/713-sout...signaler-un-probleme

Please Log in or Create an account to join the conversation.

  • Topic Author
15 Jun 2011 16:32 - 15 Jun 2011 22:36 #57497 by
Ho fatto una serie di prove e credo di aver individuato il problema.

Ripercorrendo i passi fatti per avviare la connessione da MB LIVE, mi sono reso conto che non avevo dato peso al fatto che la scheda audio USB fosse riconosciuta da MB LIVE e da MB STUDIO come "Mobile Pre" e non con il solito nome, rispettivamente "M-Audio MobilePRE USB In 1/2" per MB-LIVE e "M-Audio MobilePRE USB Out 1/2": sostanzialmente non era il driver di M-Audio a pilotare il dispositivo ma il driver nativo di Windows XP che, molto probabilmente, non ha inizializzato correttamente la scheda (probabilmente, come giustamente hai detto, l'ha inizializzata a 48kHZ, ma non l'ho verificato).

Per sistemare il problema sono andato, seguendo queste istruzioni www.m-audio.com/index.php?do=support.faq...089239a5ad8114b1b52b , in Gestione Periferiche e ho istruito Windows a caricare il driver corretto.

Dopo aver fatto alcune prove di 6-7 minuti utilizzando la codifica AAC+ 64 Kbits Stereo, tutto sembra funzionare perfettamente.


Con questo spero di aver risolto il problema. Grazie mille per l'assistenza!
Last edit: 15 Jun 2011 22:36 by .

Please Log in or Create an account to join the conversation.

More
15 Jun 2011 22:33 - 15 Jun 2011 22:36 #57509 by MB SOFT
grazie a te per il resoconto, sicuramente sara' utile ad altri utenti che usano o useranno quella stessa scheda.

Il forum non sostituisce il servizio di assistenza tecnica. Per ricevere assistenza tecnica andare a questa pagina: www.newradio.it/client/submitticket.php?step=2&deptid=4
Pour signaler un problème, lisez ici: www.mbradio.it/fr/soutien/guide/713-sout...signaler-un-probleme
Last edit: 15 Jun 2011 22:36 by .

Please Log in or Create an account to join the conversation.

Time to create page: 0.083 seconds

MB STUDIO HOME / LITE / PRO

MB STUDIO PRO / LITE MB STUDIO is a radio automation software that will allow you to create and manage your own radio station playing all your media files: jingles, commercials, news, songs, Files from internet, live streams, live inputs from your sound card, satellite feeds. Automatically download news and shows from Internet. Multiple overlapping files and/or live sources (mic, line, aux). Voice tracking. Integrated CD Ripper. Integrated jukebox to play songs requested via sms / email messages. Display current playlist on your web site.

MB RECASTER PRO

video reel32MB RECASTER features an audio recorder with scheduler, a webcast module to send streams to any Shoutcast, Icecast or Windows Media server, AutoDJ function to play randomly your own audio files from up to 4 folders, a stream receiver allowing to record or recast to your server (transcoder), an audio converter from/to any format.

MB LIVE

MB LIVEMB LIVE is a software that stream a live audio\video feed from any place to an MB STUDIO PRO automation in the main radio studio. MB LIVE make use of a TCPIP connection. This program is free for MB STUDIO PRO users